Spring Source Tool Suite

Holy crap, half a day and dozens of Google searches later, I found the 3 things necessary to install STS in Eclipse 3.5.2

Behold !

https://issuetracker.springsource.com/browse/STS-831

Adding these 3 update sites:

http://download.eclipse.org/tools/mylyn/update/e3.4
http://download.eclipse.org/tools/mylyn/update/extras
http://download.eclipse.org/tools/ajdt/35/update

The one that fixed my particular issue was this one:

http://download.eclipse.org/tools/ajdt/35/update